Repository navigation
🔒 Allow patched 1.4 advisory in audit - #784
Merged
Merged
Conversation
Contributor
There was a problem hiding this comment.
Copilot was unable to review this pull request because the user who requested the review has insufficient remaining quota.
An organization owner can choose the repository organization as the billing source for reviews requested by members with a paid Copilot license. Learn about Copilot code review billing.
Coverage Report for CI Build 40625125672Coverage remained the same at 95.446%Details
Uncovered ChangesNo uncovered changes found. Coverage RegressionsNo coverage regressions found. Coverage Stats
💛 - Coveralls |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Summary
bundler-auditwhile the 1.4.12 security release is prepared.CI failure
The
Deps Lockedrun failed only in the default Rake task'sbundler-auditcheck. It scanned the prepared 1.4.12 version and reported CVE-2026-54603 with solution>= 2.0.22. The 1.4 security backport is already on the target branch; this exception keeps the stale advisory range from blocking the release. All other jobs in that run passed or were skipped.Original failed run: https://github.com/ruby-oauth/oauth2/actions/runs/40325938814