Skip to content

Update PHP version requirement to include 8.3.0 - #1184

Merged
fashxp merged 1 commit into
1.6from
fashxp-patch-1
Oct 22, 2026
Merged

fashxp merged 1 commit into
1.6from
fashxp-patch-1

Conversation

@fashxp

@fashxp fashxp commented Oct 22, 2026

Copy link
Copy Markdown
Member

No description provided.

Copilot AI balanced review requested due to automatic review settings October 22, 2026 14:44
@fashxp fashxp added the Task label Oct 22, 2026
@fashxp fashxp added this to the 1.6.8 milestone Oct 22, 2026
@sonarqubecloud

Copy link
Copy Markdown

Copilot AI left a comment

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

🔵 Needs a closer look

The constraint change is straightforward, but compatibility with PHP 8.3 remains unverified by the existing CI coverage.

No open issues 🎉

What changed in this PR

This PR expands the package’s Composer PHP requirement to allow PHP 8.3.x while preserving support for PHP 8.0–8.2.

Changes:

  • Adds ~8.3.0 to the allowed PHP version ranges.
  • Leaves all other dependency requirements unchanged.
File Description
composer.json Extends the PHP constraint to include PHP 8.3.x.

Review effort: Balanced

@fashxp
fashxp merged commit 9b7d0d5 into 1.6 Oct 22, 2026
8 of 17 checks passed
@fashxp
fashxp deleted the fashxp-patch-1 branch October 22, 2026 15:27
@github-actions github-actions Bot locked and limited conversation to collaborators Oct 22, 2026
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.

Labels

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants